Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 07, 2025 - 10:30 UTC
Scheduled
We’re rolling out major version upgrades to the Self‑Service Portals core packages to improve performance, security, and stability. We’ll post progress here and confirm once maintenance is complete.
Posted Nov 07, 2025 - 10:21 UTC
This scheduled maintenance affected: Shelf: CA Region (Self-Service Portals).