A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2024 - 12:28 UTC
Investigating
We are aware of an issue where a recent update to Google Chrome is causing errors within the user interface of our platform. Our team is actively investigating the matter to identify the root cause and implement a fix. We will provide further updates as soon as more information is available.
Thank you for your patience and understanding.
Posted Sep 19, 2024 - 08:08 UTC
This incident affected: Shelf: EU Region (Viewing Content & Search), Shelf: CA Region (Viewing Content & Search), and Shelf: US Region (Viewing Content & Search).