The disruption to Content Intelligence service in the US region has been fully resolved.
Our engineering team successfully restored all services to their normal state. The situation has been closely monitored, and performance metrics have stabilized without further issues.
We appreciate your patience and understanding during this time.
Posted Feb 25, 2025 - 20:56 UTC
Monitoring
The Content Intelligence service in the US region has been fully restored as of 20:00 UTC. Our engineering team successfully implemented a failover solution using a recent system backup taken moments before the disruption. All user data is intact and operations performed during the outage have been properly stored.
Some users may experience brief periods of reduced performance as our systems complete the scaling process. We continue to monitor the service closely during this stabilization period and appreciate your patience throughout this event.
Posted Feb 25, 2025 - 20:00 UTC
Identified
We are currently experiencing a disruption to our Content Intelligence service in the US region that began at 17:20 UTC. Users may be unable to view analytics dashboards and charts. All data remains secure, and any changes made during this period will be properly processed once service is fully restored.
Our engineering team has identified the root cause as an underlying infrastructure issue with our service provider and is actively implementing mitigation measures, including routing operations to redundant systems. We are in direct communication with AWS support engineers via a priority incident channel and collaboratively working toward resolution.
This issue affects only the US region; EU and CA regions remain fully operational. We will provide updates as the situation progresses.
Posted Feb 25, 2025 - 17:20 UTC
This incident affected: Shelf: US Region (Insights & Analytics).