Incident with login page
Incident Report for Shelf
Resolved
This incident has been resolved.
Posted Jul 25, 2023 - 08:50 UTC
Monitoring
A fix has been implemented and we are monitoring results. Google authorization is temporarily disabled
Posted Jul 25, 2023 - 08:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 25, 2023 - 07:57 UTC
Update
We are continuing to investigate this issue.
Posted Jul 25, 2023 - 07:27 UTC
Investigating
We are currently investigating this issue.
Posted Jul 25, 2023 - 07:26 UTC
This incident affected: Shelf: CA Region (Authentication) and Shelf: US Region (Authentication).