US region: Widespread service disruption due to upstream cloud provider incident

Incident Report for Shelf

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:14 UTC

Monitoring

US region services have returned to normal operation as of 09:22 UTC. This incident stemmed from a region‑wide issue at our cloud infrastructure provider and caused intermittent errors and latency across multiple US services. Impact window: 06:48-09:22 UTC (2 hours 34 minutes). No data was lost. EU and CA regions were not affected. Thank you for your patience.
Posted Oct 20, 2025 - 09:22 UTC

Update

The issue persists. Our cloud infrastructure provider continues to experience a region-wide incident in their US‑East region. We are actively working with the provider to reduce impact.
Posted Oct 20, 2025 - 08:28 UTC

Identified

We have identified that the sign‑in failures correlate with a regional incident at our cloud infrastructure provider in their US‑East region. Customers served from our US region may see "incorrect password" messages or slow/failed requests. Our EU and CA regions remain healthy.
Posted Oct 20, 2025 - 07:24 UTC

Investigating

We are investigating reports of sign‑in failures in our US region. The first errors began at approximately 06:48 UTC. EU and CA regions remain healthy. We'll share more as we learn. Next update within 30 minutes.
Posted Oct 20, 2025 - 06:48 UTC
This incident affected: Shelf: US Region (Integrations, Authentication, Viewing Content & Search, Insights & Analytics, Emails & Notifications, Self-Service Portals, Making Changes to Content).