Degraded Search Functionality
Incident Report for Shelf
Postmortem

What Happened?

On June 9, 2023, at approximately 22:59 UTC, the Elasticsearch cluster utilized by the Shelf KMS platform experienced an inaccessibility issue in the us-east-1 region. As a consequence, certain API operations that rely on this cluster encountered timeouts, resulting in a degradation of search functionality on the Shelf KMS platform.

Impact on Customers

During the period of the incident, which lasted until June 10, 2023, at 00:18 UTC, clients using the Shelf KMS platform experienced difficulties in retrieving search results for gems. While the Gem Page remained functional and available for viewing, clients were unable to effectively locate gems via search results or navigate using the search function. The total duration of the degraded functionalities was approximately 1 hour and 19 minutes.

Why Did it Happen?

The root cause of the incident was traced back to a networking issue that occurred within Elastic Cloud, a third-party service provider that Shelf KMS relies on for hosting the Elasticsearch cluster. Due to an underlying infrastructure outage outside of our direct control, Elastic Cloud experienced disruptions that adversely affected the performance and accessibility of the Elasticsearch cluster in the us-east-1 region.

For your reference, Elastic Cloud's incident summary can be found at the following link: https://status.elastic.co/incidents/07bw653d2677

Posted Jun 13, 2023 - 19:50 UTC

Resolved
This incident has been resolved.
Posted Jun 10, 2023 - 00:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2023 - 00:26 UTC
Identified
The search functionality is currently experiencing performance issues as a result of an incident with our upstream cloud provider. For more information, please visit https://status.elastic.co/
In the meantime, we are actively working on resolving the issue through our own efforts.
Posted Jun 09, 2023 - 23:02 UTC
Investigating
We are currently investigating this issue.
Posted Jun 09, 2023 - 23:00 UTC
This incident affected: Shelf: US Region (Viewing Content & Search).